Instagram Public Search Not Working
Incident Report for StoryPorts
Resolved
Public user search on the Instagram Connector has been deprecated. Now you must have authentication privileges to a user or brand to search and use content.

As an alternative, StoryPorts has implemented a Instagram Widget (located under Studio / Modules / Widgets) that has both user and hashtag search without requiring authentication.
Posted May 30, 2019 - 09:01 EDT
Update
As of 4/4/2018 Instagram has abruptly retired their API that allowed for users to perform a public search for other users content. For example, you can no longer search for @storyports Instagram content unless the @storyports user was the one who authenticated the channel. This change was supposed to come into effect December 11, 2018 but was immediately released by Instagram for unknown reasons. The following will outline the impact to customers and steps to get content flowing back into your content blocks.

Impact to Customers:
- Any email with Content Ctrl Instagram block will trigger ET Raise Error and fail the email send.
- Any public search in StoryPorts Studio will fail and return an error message
- Any email with an Instagram Stream that uses public search (which is all of them) will:
> In App - will display error message in email body.
> On Publish - No content will display. Area will remain empty.

To get content to populate correctly again you will need to follow these steps.

Content Ctrl Users:
- Navigate to Connectors / Instagram
- Re-Authenticate all Channels to User Credentials for media you want displayed
- Access Content Blocks and Clear Search Fields for Hashtag Search and User Search. This will display the authenticated user’s media by default.
vRepublish
- Note: Any email with Content Ctrl Instagram block will trigger ET Raise Error and fail the email send.

StoryPorts Studio Users:
- Navigate to StoryPorts Studio
- On Search, Select Instagram
- Under the Instagram Icon, Select the dropdown arrow
- A dialogue will appearch. Select the Gear Icon
- Select Re-Authenticate
- Provide Instagram Permissions
- If you have multiple channels, do the same process for each channel.
Posted Apr 04, 2018 - 18:09 EDT
Identified
Instagram content using "public search" no longer returning content. We will keep you updated with the details as we uncover them.
Posted Apr 04, 2018 - 16:19 EDT