March 2017 Release Update
Incident Report for StoryPorts
Resolved
This incident has been resolved.
Posted May 11, 2017 - 14:26 EDT
Investigating
We are postponing the 2Pac March 2017 Release until this Thursday, April 6, 2017.

Producing an outstanding product for your email marketing needs is our top priority. StoryPorts is powered by delivering high quality, cutting edge technology; while administering improvements and enhancements based on our customer feedback. We felt that delaying this release until all enhancements and improvements were smooth, bug free, and ready to fly was in the best interest for everyone. We are listening, rest assured, and we are thinking of you. Until we go live with 2Pac, please visit our blog, and stay posted for any upcoming Webinars and Events.

Please be advised that this date could be delayed until a later date.
Posted Apr 04, 2017 - 15:28 EDT